XTM tip issues (Canada)

Incident Report for Regis Corp Systems

Update

Tips continue to fail. XTM has not clarified the source of the problem.

To avoid additional potential problems, will not attempt further reloads of prior day's tips unless requested by owners individually.

We will continue to monitor the situation.
Posted Feb 17, 2026 - 13:17 CST

Update

We have started tip loads for Feb 16.
Posted Feb 17, 2026 - 08:53 CST

Update

We have attempted tip loads for Feb 13-15.
Posted Feb 16, 2026 - 10:38 CST

Investigating

XTM/Everydaypayments tip payments are failing for multiple salons. If you are affected please contact XTM/Everydaypayments support at support@everydaypayments.ca.

Please log in to XTM/Everydaypayments https://managers.everydaypayments.ca/user/login to see additional updates regarding this outage.
Posted Feb 16, 2026 - 09:26 CST
This incident affects: Tip cards (XTM tips (Canada)).