XTM tip issues (Canada)

Incident Report for Regis Corp Systems

Resolved

This incident has been resolved.
Posted Feb 06, 2026 - 16:10 CST

Monitoring

XTM reports that card loads and all money movement functions are now back online and operational.
Please note that self-load transactions require one business day to settle before appearing in your wallet - per XTM.

XTM has also shared this communication https://www.paidanyday.com/newsroom/correction-xtm-inc-clarifies-rpaa-related-disclosure-and-regulatory-continuity
Posted Feb 05, 2026 - 15:45 CST

Update

Please log in to XTM/Everydaypayments https://managers.everydaypayments.ca/user/login to see additional updates regarding this outage.
Posted Feb 04, 2026 - 15:05 CST

Identified

XTM/Everydaypayments tip payments are failing for multiple salons. If you are affected please contact XTM/Everydaypayments support at support@everydaypayments.ca.
Posted Feb 04, 2026 - 10:53 CST
This incident affected: Tip cards (XTM tips (Canada)).